Using play service 9.0.2 along with module library with 7.8.0 version causing issue

I am facing an issue with play service library.
Below is what i am getting as issue with below lines.
in my app module


compile 'com.google.android.gms:play-services-gcm:9.0.2'
compile 'com.google.android.gms:play-services-location:9.0.2'
compile 'com.aman.sdk:1.0.1'

And below is my library module dependencies – also i have to put it on jcenter
But as soon as above is done along with my library included is causing issue.


dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
compile 'com.google.android.gms:play-services-ads:7.8.0'
compile 'com.google.android.gms:play-services-gcm:7.8.0'
compile 'com.android.support:support-v4:23.1.1'
}

All com.google.android.gms libraries must use the exact same version specification (mixing versions can lead to runtime crashes). Found versions 9.0.2, 7.8.0. Examples include com.google.android.gms:play-services-gcm:9.0.2 and com.google.android.gms:play-services-location:7.8.0 less… (⌘F1)
There are some combinations of libraries, or tools and libraries, that are incompatible, or can lead to bugs. One such incompatibility is compiling with a version of the Android support libraries that is not the latest version (or in particular, a version lower than your targetSdkVersion.)

Any help would be thank full.

Source: java

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.