unknown error while integrating facebook sdk

I am getting an unknown error while integrating Facebook sdk 4.1.2 for my android app in eclipse.
The problem is that there is no indication of errors in any source file, but the error symbol(red cross) is displayed at root of project. And it is not possible to run the project in emulator due to that error(s).

Actually, i have changed the compiler compliance to 1.7.
So it is showing the error “Android requires compiler compliance level 5.0 or 6.0. Found ‘1.7’ instead. Please use Android Tools > Fix Project Properties.” in console.

1. Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.   

2. The container 'Android Dependencies' references non existing library 'F:androidworkspacefacebookbinfacebook.jar'    

3. The project cannot be built until build path errors are resolved 

I hope everyone helps to solve my problem and Thanks in advance.


Source: eclipse

Leave a Reply