Unable to install sqlite on ubuntu

I am new in ubuntu.
I am using php of version 5.4.39-1+deb.sury.org~lucid+2 and PDO drivers is only mysql. Now I need to install PDO Driver for SQLite 3.x. I have already installed sqlite of version 3.6.22.
After googling I just run the following command :

sudo apt-get install php5-sqlite

But getting the following error:

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Now it is showing the following issue after killing the other apt-get process:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-sqlite: Depends: phpapi-20090626+lfs
               Depends: php5-common (= 5.3.2-1ubuntu4.30) but 5.4.39-1+deb.sury.org~lucid+2 is to be installed
E: Broken packages

What might be the issue? Please help me to install PDO Driver for SQLite 3.x.

Thanks in advance.


Source: ubuntu

Leave a Reply