OSX/Localhost Apache shuts down, leaving me with no clue how to solve it

I’m now struggling for a day to get Apache, PHP and MySql working on a OSX 10.10. I just got the laptop from a co-worker who was still working on 10.7 so i updated to 10.10 directly. I’m fairly familiar with the installation process (i did it a few times on my own laptops, but those where all on 10.8, 10.9 and 10.10).

Because it works there i copied my working httpd.conf content and placed it in the same file on this computer, but without a result.

When i run a apachectl configtest it sais everything is oke, but my error_log shows me the following

[09:35:45.872331 2015] [mpm_prefork:notice] [pid 1147] AH00169: caught SIGTERM, shutting down
[09 09:35:46.449577 2015] [mpm_prefork:notice] [pid 1169] AH00163: Apache/2.4.10 (Unix) PHP/5.5.20 configured -- resuming normal operations
[09:35:46.449649 2015] [core:notice] [pid 1169] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

Also when i go to localhost/~username i get a Forbidden message.

I do have a ServerName localhost declared in my httpd.conf (mentioned a lot elsewhere on the internet)

My vhost file looks like this:

<VirtualHost *:80>
    ServerAdmin user@domain.com
    DocumentRoot "/Users/username/Sites/folder/webroot"
    ServerName site.dev
    ServerAlias www.site.dev
    ErrorLog "/private/var/log/apache2/site.dev-error_log"
    CustomLog "/private/var/log/apache2/site.dev-access_log" common

The error logs of my vhosts are empty.

My hosts file looks like this:       localhost broadcasthost
::1             localhost       site.dev

I’m out of options so any help would be really appreciated!

Source: apache

Leave a Reply