Is it possible to update the PyDev plug-in bundled with Aptana?

I have Aptana Studio 3.6.0 installed on Luna 4.4.2 (running on Ubuntu 15.04 64 bit). Aptana bundles in a considerably old version of PyDev (3.0.0) that is largely non functional due to this bug.

The current PyDev release (4.1) should fix the issues I am struggling with, but if I try to update Eclipse tells me Aptana must be removed.

Is it possible in any way to update PyDev while keeping Aptana installed? Or somehow unbundle PyDev from Aptana?


Source: eclipse

Leave a Reply