GNU Make – Switch GCC version – Mod_perl apache unix

Hi all I saw Make GNU make use a different compiler

I’ve been trying to get mod_perl installed and whenever I go to run the “make” command and anything after that I get

/bin/sh: /usr/bin/gcc/3.3/bin/gcc: No such file or directory

Note this is a work environment so they have different versions installed.

If I do a gcc –version I get

gcc (GCC) 4.7.2

I tried to do make cc=/path/to/other/gcc but it never works. It does not appear to have a $(CC) variable set in the Makefile.PL

So what can I do to make this work? There is no version 3.3 anymore in my environment.


Source: gcc

Leave a Reply