Error while installing Dbeaver On Ubuntu 14.04

I am trying to install Dbeaver on Ubuntu (14.04) but i am unable to install. Seems like there is some issue with Java Installation.

Installtion Process

 1. $ sudo apt-get install gdebi
 2. $ wget http://dbeaver.jkiss.org/files/dbeaver_3.4.5_i386.deb
 3. $ gdebi dbeaver_3.4.5_i386.deb

I get this error when tring to install :

webwerks@BT-R4P9:~/Downloads$ sudo gdebi dbeaver_3.4.5_i386.deb 
Reading package lists... Done
Building dependency tree 
Reading state information... Done
Building data structures... Done 
Building data structures... Done 

DBeaver
Universal Database Manager
Do you want to install the software package? [y/N]:y
Selecting previously unselected package dbeaver.
(Reading database ... 183011 files and directories currently installed.)
Preparing to unpack dbeaver_3.4.5_i386.deb ...
Unpacking dbeaver (3.4.5) ...
dpkg: dependency problems prevent configuration of dbeaver:
dbeaver depends on java7-runtime.

dpkg: error processing package dbeaver (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:
dbeaver

When I run java -version I get this :

java version "1.7.0_80"
Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)


Source: ubuntu

Leave a Reply