Eclipse thinks I only have Java 1.6, but when checking java-version in terminal it displays 1.7. Help :)

I just downloaded Eclipse, and it said “Version 1.7 or greater is required” for Java. Then I downloaded Java 1.7 and installed it and all that, and even restarted my computer. When I check my Java version in the terminal, it says Java 1.7, so why can’t Eclipse recognize Java 1.7?

Thanks a lot! 🙂

My question isn’t a duplicate of Running Eclipse on Mac – JVM Version 1.7 or greater is required because I installed the entire JDK 7 and my computer recognizes Java 1.7. Right now, I can’t even open Eclipse.


Source: eclipse

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.