dependencies issue in ubuntu

I am a new ubuntu user. the issue is that I have been trying to install odoo on my PC and it keeps on giving me errors about dependencies. this is what appears:

libmariadbclient18 : Depends: libmysqlclient18 (= 10.0.20+maria-1~trusty) but 5.5.43-0ubuntu0.14.04.1 is to be installed E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

I tried sudo apt-get install -f

here is the error that it gives:

dpkg: error processing archive /var/cache/apt/archives/libmysqlclient18_10.0.20+maria-1~trusty_amd64.deb (–unpack): libmysqlclient18:amd64 10.0.20+maria-1~trusty (Multi-Arch: no) is not co-installable with libmysqlclient18 which has multiple installed instances E: Sub-process /usr/bin/dpkg returned an error code (1)

I dont get whats this thing with trusty and all. Also I tried installing Mysql n Mariadb separately but it aint working…
Along with a solution to this, I would like someone to explain me the issue so that I can resolve such issues next time they occur.


Source: ubuntu

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.