clang error unknown argument -fno-tree-vrp

Since few days, I’m not able anymore to do npm install without this error.
Here is my log file:

npm install
npm WARN package.json pipes2js@0.0.1 No license field.

iconv@2.1.8 install /opt/pipes2js/node_modules/xml2js-expat/node_modules/node-expat/node_modules/iconv
node-gyp rebuild

make: Entering directory /opt/pipes2js/node_modules/xml2js-expat/node_modules/node-expat/node_modules/iconv/build
CC(target) Release/obj.target/libiconv/deps/libiconv/lib/iconv.o
clang: error: unknown argument: -fno-tree-vrp
make: *** [Release/obj.target/libiconv/deps/libiconv/lib/iconv.o] Error 1
make: Leaving directory /opt/pipes2js/node_modules/xml2js-expat/node_modules/node-expat/node_modules/iconv/build
gyp ERR! build error
gyp ERR! stack Error: make failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:269:23)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:98:17)
gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:797:12)
gyp ERR! System Linux 3.16.0-30-generic
gyp ERR! command “node” “/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild”
gyp ERR! cwd /opt/pipes2js/node_modules/xml2js-expat/node_modules/node-expat/node_modules/iconv
gyp ERR! node -v v0.10.25
gyp ERR! node-gyp -v v1.0.3
gyp ERR! not ok
npm ERR! Linux 3.16.0-30-generic
npm ERR! argv “node” “/usr/local/bin/npm” “install”
npm ERR! node v0.10.25
npm ERR! npm v2.10.1
npm ERR! code ELIFECYCLE
npm ERR! iconv@2.1.8 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the iconv@2.1.8 install script ‘node-gyp rebuild’.
npm ERR! This is most likely a problem with the iconv package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls iconv
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR! /opt/pipes2js/npm-debug.log

I’m on Ubuntu 14.04. I have nodejs (0.10.25) and node-legacy install, clang 3.4, npm 2.10.1


Source: ubuntu

Leave a Reply